Latest changes
authorChris Sharp <csharp@georgialibraries.org>
Wed, 13 Oct 2021 17:22:59 +0000 (13:22 -0400)
committerChris Sharp <csharp@georgialibraries.org>
Wed, 13 Oct 2021 17:22:59 +0000 (13:22 -0400)
12 files changed:
build_evergreen2_debs
files_for_build/CONTROL
files_for_build/CONTROL-cluster
files_for_build/config [changed mode: 0755->0644]
files_for_build/control
files_for_build/control-cluster
files_for_build/eg_database [changed mode: 0755->0644]
files_for_build/postinst [changed mode: 0755->0644]
files_for_build/postinst-cluster [changed mode: 0755->0644]
files_for_build/postrm [changed mode: 0755->0644]
files_for_build/rules [changed mode: 0755->0644]
files_for_build/rules-custom [changed mode: 0755->0644]

index d81362e..97a4923 100755 (executable)
@@ -18,7 +18,8 @@
 #    You should have received a copy of the GNU General Public License
 #    along with this program.  If not, see <http://www.gnu.org/licenses/>.
 #
-SCRIPT_VERSION=16.04.28
+#  set -x
+SCRIPT_VERSION=18.04.5
 
 
 OPENILS_BIN="/openils/bin"
@@ -30,11 +31,11 @@ WORKDIR="$(dirname $(readlink -f -- $0))"
 echo;echo "WORKDIR is: $WORKDIR"
 echo
 #WORKDIR=`pwd`
-if [ ! -z $1 ]; then
-       VERSION=$1
-else
-VERSION="3.4.0"
-fi
+#if [ ! -z $1 ]; then
+#      VERSION=$1
+#else
+VERSION="3.6.1"
+#fi
 echo "Building evergreen-ils $VERSION"
 # Customized files need to build the package.
 BUILDFILESDIR="${WORKDIR}/files_for_build"
@@ -49,7 +50,6 @@ EG_CUSTOMIZATIONS_FILE="$WORKDIR/files_for_build/customized/evergreen_customizat
 BUILD_TYPE_FILE="Last_Build_Type.txt"
 
 echo;echo "customizations file is: $EG_CUSTOMIZATIONS_FILE"
-sleep 3
 
 EVERGREEN_PREFIX="/openils"
 #ORIG_FOLDER="/home/opensrf/develop/evergreen2/"
@@ -270,15 +270,23 @@ sed -i 's/$(DESTDIR)$(oilsincludedir)/$(oilsincludedir)/g' ${SOURCE_FOLDER}/Open
 #####################################################################################################################
 #####################################################################################################################
 
-#Debian doesn't like having the same files provided by multiple packages. Rename the example files provided by evergreen that conflict with opensrf.
+
+
+####FIXME
+##Debian doesn't like having the same files provided by multiple packages. Rename the example files provided by evergreen that conflict with opensrf.
+
+
+
 sed -i 's/opensrf.xml.example/opensrf.xml.evergreen.example/g' ${SOURCE_FOLDER}/Open-ILS/src/Makefile.in
-#sed -i 's/opensrf.xml.example/opensrf.xml.evergreen.example/g' ${SOURCE_FOLDER}/Open-ILS/src/Makefile.am
+sed -i 's/opensrf.xml.example/opensrf.xml.evergreen.example/g' ${SOURCE_FOLDER}/Open-ILS/src/Makefile.am
 sed -i 's/opensrf_core.xml.example/opensrf_core.xml.evergreen.example/g' ${SOURCE_FOLDER}/Open-ILS/src/Makefile.in
-#sed -i 's/opensrf_core.xml.example/opensrf_core.xml.evergreen.example/g' ${SOURCE_FOLDER}/Open-ILS/src/Makefile.am
+sed -i 's/opensrf_core.xml.example/opensrf_core.xml.evergreen.example/g' ${SOURCE_FOLDER}/Open-ILS/src/Makefile.am
+echo "HERE I AM, HEERE I AM, HOW DO YOU DO?"
+
 mv ${SOURCE_FOLDER}/Open-ILS/examples/opensrf.xml.example ${SOURCE_FOLDER}/Open-ILS/examples/opensrf.xml.evergreen.example
 mv ${SOURCE_FOLDER}/Open-ILS/examples/opensrf_core.xml.example ${SOURCE_FOLDER}/Open-ILS/examples/opensrf_core.xml.evergreen.example
 
-
+mkdir -p ${SOURCE_FOLDER}/debian/evergreen-ils/etc/apache2/mods-available/
 #mkdir -p ${SOURCE_FOLDER}/debian/evergreen-ils/etc/apache2/sites-available
 #cp -Rv ${SOURCE_FOLDER}/Open-ILS/examples/apache/eg.conf       ${SOURCE_FOLDER}/debian/evergreen-ils/etc/apache2/sites-available/
 #cp -Rv ${SOURCE_FOLDER}/Open-ILS/examples/apache/eg_vhost.conf ${SOURCE_FOLDER}/debian/evergreen-ils/etc/apache2/
@@ -309,8 +317,10 @@ mv ${SOURCE_FOLDER}/Open-ILS/examples/opensrf_core.xml.example ${SOURCE_FOLDER}/
 #copy support scripts into openils/bin since /home/opensrf/<src> isn't available anymore
 mkdir -p "${DEST_ROOT}${EVERGREEN_PREFIX}/bin"
 mkdir -p "${DEST_ROOT}${EVERGREEN_PREFIX}/share/doc/examples/"
-cp -rv ${SOURCE_FOLDER}/Open-ILS/src/support-scripts/* "${DEST_ROOT}${EVERGREEN_PREFIX}/bin/"
-cp -rv ${SOURCE_FOLDER}/Open-ILS/src/sql "${DEST_ROOT}${EVERGREEN_PREFIX}/share/doc/examples/"
+
+echo "Copying support scripts and sql scripts"
+cp -r ${SOURCE_FOLDER}/Open-ILS/src/support-scripts/* "${DEST_ROOT}${EVERGREEN_PREFIX}/bin/"
+cp -r ${SOURCE_FOLDER}/Open-ILS/src/sql "${DEST_ROOT}${EVERGREEN_PREFIX}/share/doc/examples/"
 
 
 
index 494ee54..c2241d2 100644 (file)
@@ -1,13 +1,13 @@
 Package: evergreen-ils
 Source: evergreen
-Version: 3.2.3
+Version: 3.6.1
 Section: web
 Priority: extra
 Architecture: amd64
 Maintainer: Pines Admins <pines-admins@georgialibraries.org>
 Homepage: http://open-ils.org
 Architecture: amd64
-Depends: ${shlibs:Depends}, ${misc:Depends}, apache2-dev, aspell, aspell-en, autoconf,automake,gcc,libapache2-mod-perl2, libapache2-mod-rpaf, libbusiness-creditcard-perl, libbusiness-isbn-data-perl, libbusiness-isbn-perl,libbusiness-issn-perl, libbusiness-onlinepayment-authorizenet-perl, libbusiness-onlinepayment-payflowpro-perl, libbusiness-onlinepayment-paypal-perl, libbusiness-onlinepayment-perl, libbusiness-stripe-perl, libbz2-dev, libclass-dbi-frozen-301-perl, libdate-manip-perl, libdatetime-format-builder-perl, libdatetime-format-iso8601-perl, libdatetime-format-mail-perl, libdatetime-perl, libdatetime-set-perl, libdatetime-timezone-perl, libdbd-pg-perl, libdbd-pgsql, libdbi1, libdbi-dev, libemail-address-perl, libemail-send-perl, libemail-simple-perl, libexcel-writer-xlsx-perl, libgd-graph3d-perl, libhtml-defang-perl, libjson-perl, libjson-xs-perl,liblibrary-callnumber-lc-perl,liblocale-maketext-lexicon-perl, liblog-log4perl-perl, libmarc-charset-perl, libmarc-record-perl, libmarc-xml-perl, libmodule-pluggable-perl, libncurses5-dev, libnet-ip-perl, libnet-ldap-perl,libnet-server-perl, libnet-ssh2-perl, libnet-z3950-simple2zoom-perl, libnet-z3950-simpleserver-perl, libnet-z3950-zoom-perl,libnspr4-dev, libole-storage-lite-perl, libparent-perl, libparse-recdescent-perl, libpcre3-dev, libpq5, libpq-dev, libreturn-value-perl, librose-uri-perl,librpc-xml-perl, libsoap-lite-perl, libsru-perl, libssh2-1-dev, libtemplate-plugin-posix-perl, libtest-output-perl, libtest-warn-perl, libtext-aspell-perl, libtext-csv-perl, libtool,libuniversal-require-perl, libunix-syslog-perl, libuuid-tiny-perl,libxml-libxml-perl,libxml-libxslt-perl, libyaz-dev, nodejs-legacy,npm, postgresql-9.5,postgresql-client-9.5, postgresql-contrib-9.5,postgresql-plperl-9.5,postgresql-server-dev-9.5, yaz
+Depends: ${shlibs:Depends}, ${misc:Depends}, apache2-dev, aspell, aspell-en, autoconf,automake,gcc,libapache2-mod-perl2, libapache2-mod-php7.2, libapache2-mod-rpaf, libbusiness-creditcard-perl, libbusiness-isbn-data-perl, libbusiness-isbn-perl,libbusiness-issn-perl, libbusiness-onlinepayment-authorizenet-perl, libbusiness-onlinepayment-payflowpro-perl, libbusiness-onlinepayment-paypal-perl, libbusiness-onlinepayment-perl, libbusiness-stripe-perl, libbz2-dev, libclass-dbi-frozen-301-perl, libdate-manip-perl, libdatetime-format-builder-perl, libdatetime-format-iso8601-perl, libdatetime-format-mail-perl, libdatetime-perl, libdatetime-set-perl, libdatetime-timezone-perl, libdbd-pg-perl, libdbd-pgsql, libdbi1, libdbi-dev, libemail-address-perl, libemail-mime-perl, libemail-send-perl, libemail-simple-perl, libexcel-writer-xlsx-perl, libgd-graph3d-perl, libhtml-defang-perl, libhttp-async-perl, libjson-perl, libjson-xs-perl,liblibrary-callnumber-lc-perl,liblocale-maketext-lexicon-perl, liblog-log4perl-perl, libmarc-charset-perl, libmarc-record-perl, libmarc-xml-perl, libmodule-pluggable-perl, libncurses5-dev, libnet-ip-perl, libnet-ldap-perl,libnet-server-perl, libnet-ssh2-perl, libnet-z3950-simple2zoom-perl, libnet-z3950-simpleserver-perl, libnet-z3950-zoom-perl,libnspr4-dev, libole-storage-lite-perl, libparent-perl, libparse-recdescent-perl, libpcre3-dev, libpq5, libpq-dev, libreturn-value-perl, librose-uri-perl,librpc-xml-perl, libsoap-lite-perl, libsru-perl, libssh2-1-dev, libssl-dev  libtemplate-plugin-posix-perl, libtest-output-perl, libtest-warn-perl, libtext-aspell-perl, libtext-csv-perl, libtool,libuniversal-require-perl, libunix-syslog-perl, libuuid-tiny-perl,libxml-libxml-perl,libxml-libxslt-perl, libyaz-dev, php7.2, php7.2-gd, php7.2-pgsql, php7.2-xml, php7.2-dev, php-memcache, php-pear,  postgresql-9.6,postgresql-client-9.6, postgresql-contrib-9.6,postgresql-plperl-9.6,postgresql-server-dev-9.6, yaz
 
 Description: Evergreen Library Management Sofware.
  Evergreen is open-source, consortial-quality
index 7e79b92..bb301db 100644 (file)
@@ -1,13 +1,13 @@
 Package: evergreen-ils
 Source: evergreen
-Version: 3.2.3
+Version: 3.6.1
 Section: web
 Priority: extra
 Architecture: amd64
 Maintainer: Pines Admins <pines-admins@georgialibraries.org>
 Homepage: http://open-ils.org
 Architecture: amd64
-Depends: ${shlibs:Depends}, ${misc:Depends}, apache2-dev, aspell, aspell-en, autoconf,automake,gcc,libapache2-mod-perl2, libapache2-mod-rpaf, libbusiness-creditcard-perl, libbusiness-isbn-data-perl, libbusiness-isbn-perl,libbusiness-issn-perl, libbusiness-onlinepayment-authorizenet-perl, libbusiness-onlinepayment-payflowpro-perl, libbusiness-onlinepayment-paypal-perl, libbusiness-onlinepayment-perl, libbusiness-stripe-perl, libbz2-dev, libclass-dbi-frozen-301-perl, libdate-manip-perl, libdatetime-format-builder-perl, libdatetime-format-iso8601-perl, libdatetime-format-mail-perl, libdatetime-perl, libdatetime-set-perl, libdatetime-timezone-perl, libdbd-pg-perl, libdbd-pgsql, libdbi1, libdbi-dev, libemail-address-perl, libemail-send-perl, libemail-simple-perl, libexcel-writer-xlsx-perl, libgd-graph3d-perl, libhtml-defang-perl, libjson-perl, libjson-xs-perl,liblibrary-callnumber-lc-perl,liblocale-maketext-lexicon-perl, liblog-log4perl-perl, libmarc-charset-perl, libmarc-record-perl, libmarc-xml-perl, libmodule-pluggable-perl, libncurses5-dev, libnet-ip-perl, libnet-ldap-perl,libnet-server-perl, libnet-ssh2-perl, libnet-z3950-simple2zoom-perl, libnet-z3950-simpleserver-perl, libnet-z3950-zoom-perl,libnspr4-dev, libole-storage-lite-perl, libparent-perl, libparse-recdescent-perl, libpcre3-dev, libpq5, libpq-dev, libreturn-value-perl, librose-uri-perl,librpc-xml-perl, libsoap-lite-perl, libsru-perl, libssh2-1-dev, libtemplate-plugin-posix-perl, libtest-output-perl, libtest-warn-perl, libtext-aspell-perl, libtext-csv-perl, libtool,libuniversal-require-perl, libunix-syslog-perl, libuuid-tiny-perl,libxml-libxml-perl,libxml-libxslt-perl, libyaz-dev, nodejs-legacy,npm, postgresql-client-9.5, yaz
+Depends: ${shlibs:Depends}, ${misc:Depends}, apache2-dev, aspell, aspell-en, autoconf,automake,gcc,libapache2-mod-perl2, libapache2-mod-php7.2, libapache2-mod-rpaf, libbusiness-creditcard-perl, libbusiness-isbn-data-perl, libbusiness-isbn-perl,libbusiness-issn-perl, libbusiness-onlinepayment-authorizenet-perl, libbusiness-onlinepayment-payflowpro-perl, libbusiness-onlinepayment-paypal-perl, libbusiness-onlinepayment-perl, libbusiness-stripe-perl, libbz2-dev, libclass-dbi-frozen-301-perl, libdate-manip-perl, libdatetime-format-builder-perl, libdatetime-format-iso8601-perl, libdatetime-format-mail-perl, libdatetime-perl, libdatetime-set-perl, libdatetime-timezone-perl, libdbd-pg-perl, libdbd-pgsql, libdbi1, libdbi-dev, libemail-address-perl, libemail-mime-perl, libemail-send-perl, libemail-simple-perl, libexcel-writer-xlsx-perl, libgd-graph3d-perl, libhtml-defang-perl, libhttp-async-perl, libjson-perl, libjson-xs-perl,liblibrary-callnumber-lc-perl,liblocale-maketext-lexicon-perl, liblog-log4perl-perl, libmarc-charset-perl, libmarc-record-perl, libmarc-xml-perl, libmodule-pluggable-perl, libncurses5-dev, libnet-ip-perl, libnet-ldap-perl,libnet-server-perl, libnet-ssh2-perl, libnet-z3950-simple2zoom-perl, libnet-z3950-simpleserver-perl, libnet-z3950-zoom-perl,libnspr4-dev, libole-storage-lite-perl, libparent-perl, libparse-recdescent-perl, libpcre3-dev, libpq5, libpq-dev, libreturn-value-perl, librose-uri-perl,librpc-xml-perl, libsoap-lite-perl, libsru-perl, libssh2-1-dev, libssl-dev, libtemplate-plugin-posix-perl, libtest-output-perl, libtest-warn-perl, libtext-aspell-perl, libtext-csv-perl, libtool,libuniversal-require-perl, libunix-syslog-perl, libuuid-tiny-perl,libxml-libxml-perl,libxml-libxslt-perl, libyaz-dev, php7.2, php7.2-gd, php7.2-pgsql, php7.2-xml, php7.2-dev, php-memcache, php-pear, postgresql-client-9.6, yaz
 
 Description: Evergreen Library Management Sofware.
  Evergreen is open-source, consortial-quality
old mode 100755 (executable)
new mode 100644 (file)
index 3bcdcdb..5062343 100644 (file)
@@ -2,13 +2,13 @@ Source: evergreen-ils
 Section: web
 Priority: extra
 Maintainer: Pines Admins <pines-admins@georgialibraries.org>
-Build-Depends: aspell, libc6 (>= 2.3), libmemcached-dev, libncurses5, libreadline6, libxml2 (>= 2.7.4), debconf (>= 0.5), debhelper (>= 7.0.50~), autotools-dev, autoconf, automake, build-essential, libexpat1-dev, libgcrypt11-dev, libgdbm-dev, libperl-dev, libreadline6-dev, libxml2-dev, libxslt1-dev, python-dev, zlib1g-dev, libncurses5-dev, libnspr4-dev, libssh2-1-dev, libbz2-dev, libtest-warn-perl, libtest-output-perl, libbusiness-stripe-perl, yaz, libyaz-dev, libdbd-pgsql
+Build-Depends: aspell, libc6 (>= 2.3), libmemcached-dev, libncurses5, libreadline7, libxml2 (>= 2.7.4), debconf (>= 0.5), debhelper (>= 7.0.50~), autotools-dev, autoconf, automake, build-essential, libexpat1-dev, libgcrypt11-dev, libgdbm-dev, libperl-dev, libreadline-dev, libxml2-dev, libxslt1-dev, python-dev, zlib1g-dev, libncurses5-dev, libnspr4-dev, libssh2-1-dev, libbz2-dev, libtest-warn-perl, libtest-output-perl, libbusiness-stripe-perl, yaz, libyaz-dev, libdbd-pgsql
 Standards-Version: 3.8.4
 Homepage: http://open-ils.org
 
 Package: evergreen-ils
 Architecture: amd64
-Depends: ${shlibs:Depends}, ${misc:Depends}, apache2-dev, aspell, aspell-en, autoconf,automake,gcc,libapache2-mod-perl2, libapache2-mod-rpaf, libbusiness-creditcard-perl, libbusiness-isbn-data-perl, libbusiness-isbn-perl,libbusiness-issn-perl, libbusiness-onlinepayment-authorizenet-perl, libbusiness-onlinepayment-payflowpro-perl, libbusiness-onlinepayment-paypal-perl, libbusiness-onlinepayment-perl, libbusiness-stripe-perl, libbz2-dev, libclass-dbi-frozen-301-perl, libdate-manip-perl, libdatetime-format-builder-perl, libdatetime-format-iso8601-perl, libdatetime-format-mail-perl, libdatetime-perl, libdatetime-set-perl, libdatetime-timezone-perl, libdbd-pg-perl, libdbd-pgsql, libdbi1, libdbi-dev, libemail-address-perl, libemail-send-perl, libemail-simple-perl, libexcel-writer-xlsx-perl, libgd-graph3d-perl, libhtml-defang-perl, libjson-perl, libjson-xs-perl,liblibrary-callnumber-lc-perl,liblocale-maketext-lexicon-perl, liblog-log4perl-perl, libmarc-charset-perl, libmarc-record-perl, libmarc-xml-perl, libmodule-pluggable-perl, libncurses5-dev, libnet-ip-perl, libnet-ldap-perl,libnet-server-perl, libnet-ssh2-perl, libnet-z3950-simple2zoom-perl, libnet-z3950-simpleserver-perl, libnet-z3950-zoom-perl,libnspr4-dev, libole-storage-lite-perl, libparent-perl, libparse-recdescent-perl, libpcre3-dev, libpq5, libpq-dev, libreturn-value-perl, librose-uri-perl,librpc-xml-perl, libsoap-lite-perl, libsru-perl, libssh2-1-dev, libtemplate-plugin-posix-perl, libtest-output-perl, libtest-warn-perl, libtext-aspell-perl, libtext-csv-perl, libtool,libuniversal-require-perl, libunix-syslog-perl, libuuid-tiny-perl,libxml-libxml-perl,libxml-libxslt-perl, libyaz-dev, nodejs-legacy,npm, postgresql-9.5,postgresql-client-9.5, postgresql-contrib-9.5,postgresql-plperl-9.5,postgresql-server-dev-9.5, yaz
+Depends: ${shlibs:Depends}, ${misc:Depends}, apache2-dev, aspell, aspell-en, autoconf, automake, gcc, libapache2-mod-perl2, libapache2-mod-php7.2, libapache2-mod-rpaf, libbusiness-creditcard-perl, libbusiness-isbn-data-perl, libbusiness-isbn-perl,libbusiness-issn-perl, libbusiness-onlinepayment-authorizenet-perl, libbusiness-onlinepayment-payflowpro-perl, libbusiness-onlinepayment-paypal-perl, libbusiness-onlinepayment-perl, libbusiness-stripe-perl, libbz2-dev, libclass-dbi-frozen-301-perl, libdate-manip-perl, libdatetime-format-builder-perl, libdatetime-format-iso8601-perl, libdatetime-format-mail-perl, libdatetime-perl, libdatetime-set-perl, libdatetime-timezone-perl, libdbd-pg-perl, libdbd-pgsql, libdbi1, libdbi-dev, libemail-address-perl, libemail-mime-perl, libemail-send-perl, libemail-simple-perl, libexcel-writer-xlsx-perl, libgd-graph3d-perl, libhtml-defang-perl, libhttp-async-perl, libjson-perl, libjson-xs-perl,liblibrary-callnumber-lc-perl,liblocale-maketext-lexicon-perl, liblog-log4perl-perl, libmarc-charset-perl, libmarc-record-perl, libmarc-xml-perl, libmodule-pluggable-perl, libncurses5-dev, libnet-ip-perl, libnet-ldap-perl,libnet-server-perl, libnet-ssh2-perl, libnet-z3950-simple2zoom-perl, libnet-z3950-simpleserver-perl, libnet-z3950-zoom-perl,libnspr4-dev, libole-storage-lite-perl, libparent-perl, libparse-recdescent-perl, libpcre3-dev, libpq5, libpq-dev, libreturn-value-perl, librose-uri-perl,librpc-xml-perl, libsoap-lite-perl, libsru-perl, libssh2-1-dev, libssl-dev, libtemplate-plugin-posix-perl, libtest-output-perl, libtest-warn-perl, libtext-aspell-perl, libtext-csv-perl, libtool,libuniversal-require-perl, libunix-syslog-perl, libuuid-tiny-perl,libxml-libxml-perl,libxml-libxslt-perl, libyaz-dev, php7.2, php7.2-gd, php7.2-pgsql, php7.2-xml, php7.2-dev, php-memcache, php-pear, postgresql-9.6, postgresql-client-9.6, postgresql-contrib-9.6, postgresql-plperl-9.6, postgresql-server-dev-9.6, yaz
 Description: Evergreen Library Management Sofware.
  Evergreen is open-source, consortial-quality 
  library software to help library users find 
index b631e76..a7503da 100644 (file)
@@ -2,13 +2,13 @@ Source: evergreen-ils
 Section: web
 Priority: extra
 Maintainer: Pines Admins <pines-admins@georgialibraries.org>
-Build-Depends: aspell, libc6 (>= 2.3), libmemcached-dev, libncurses5, libreadline6, libxml2 (>= 2.7.4), debconf (>= 0.5), debhelper (>= 7.0.50~), autotools-dev, autoconf, automake, build-essential, libexpat1-dev, libgcrypt11-dev, libgdbm-dev, libperl-dev, libreadline6-dev, libxml2-dev, libxslt1-dev, python-dev, zlib1g-dev, libncurses5-dev, libnspr4-dev, libssh2-1-dev, libbz2-dev, libtest-warn-perl, libtest-output-perl, libbusiness-stripe-perl, yaz, libyaz-dev, libdbd-pgsql
+Build-Depends: aspell, libc6 (>= 2.3), libmemcached-dev, libncurses5, libreadline7, libxml2 (>= 2.7.4), debconf (>= 0.5), debhelper (>= 7.0.50~), autotools-dev, autoconf, automake, build-essential, libexpat1-dev, libgcrypt11-dev, libgdbm-dev, libperl-dev, libreadline-dev, libxml2-dev, libxslt1-dev, python-dev, zlib1g-dev, libncurses5-dev, libnspr4-dev, libssh2-1-dev, libbz2-dev, libtest-warn-perl, libtest-output-perl, libbusiness-stripe-perl, yaz, libyaz-dev, libdbd-pgsql
 Standards-Version: 3.8.4
 Homepage: http://open-ils.org
 
 Package: evergreen-ils
 Architecture: amd64
-Depends: ${shlibs:Depends}, ${misc:Depends}, apache2-dev, aspell, aspell-en, autoconf,automake,gcc,libapache2-mod-perl2, libapache2-mod-rpaf, libbusiness-creditcard-perl, libbusiness-isbn-data-perl, libbusiness-isbn-perl,libbusiness-issn-perl, libbusiness-onlinepayment-authorizenet-perl, libbusiness-onlinepayment-payflowpro-perl, libbusiness-onlinepayment-paypal-perl, libbusiness-onlinepayment-perl, libbusiness-stripe-perl, libbz2-dev, libclass-dbi-frozen-301-perl, libdate-manip-perl, libdatetime-format-builder-perl, libdatetime-format-iso8601-perl, libdatetime-format-mail-perl, libdatetime-perl, libdatetime-set-perl, libdatetime-timezone-perl, libdbd-pg-perl, libdbd-pgsql, libdbi1, libdbi-dev, libemail-address-perl, libemail-send-perl, libemail-simple-perl, libexcel-writer-xlsx-perl, libgd-graph3d-perl, libhtml-defang-perl, libjson-perl, libjson-xs-perl,liblibrary-callnumber-lc-perl,liblocale-maketext-lexicon-perl, liblog-log4perl-perl, libmarc-charset-perl, libmarc-record-perl, libmarc-xml-perl, libmodule-pluggable-perl, libncurses5-dev, libnet-ip-perl, libnet-ldap-perl,libnet-server-perl, libnet-ssh2-perl, libnet-z3950-simple2zoom-perl, libnet-z3950-simpleserver-perl, libnet-z3950-zoom-perl,libnspr4-dev, libole-storage-lite-perl, libparent-perl, libparse-recdescent-perl, libpcre3-dev, libpq5, libpq-dev, libreturn-value-perl, librose-uri-perl,librpc-xml-perl, libsoap-lite-perl, libsru-perl, libssh2-1-dev, libtemplate-plugin-posix-perl, libtest-output-perl, libtest-warn-perl, libtext-aspell-perl, libtext-csv-perl, libtool,libuniversal-require-perl, libunix-syslog-perl, libuuid-tiny-perl,libxml-libxml-perl,libxml-libxslt-perl, libyaz-dev, nodejs-legacy,npm, postgresql-client-9.5, yaz
+Depends: ${shlibs:Depends}, ${misc:Depends}, apache2-dev, aspell, aspell-en, autoconf, automake, gcc, libapache2-mod-perl2, libapache2-mod-php7.2, libapache2-mod-rpaf, libbusiness-creditcard-perl, libbusiness-isbn-data-perl, libbusiness-isbn-perl,libbusiness-issn-perl, libbusiness-onlinepayment-authorizenet-perl, libbusiness-onlinepayment-payflowpro-perl, libbusiness-onlinepayment-paypal-perl, libbusiness-onlinepayment-perl, libbusiness-stripe-perl, libbz2-dev, libclass-dbi-frozen-301-perl, libdate-manip-perl, libdatetime-format-builder-perl, libdatetime-format-iso8601-perl, libdatetime-format-mail-perl, libdatetime-perl, libdatetime-set-perl, libdatetime-timezone-perl, libdbd-pg-perl, libdbd-pgsql, libdbi1, libdbi-dev, libemail-address-perl, libemail-mime-perl, libemail-send-perl, libemail-simple-perl, libexcel-writer-xlsx-perl, libgd-graph3d-perl, libhtml-defang-perl, libhttp-async-perl, libjson-perl, libjson-xs-perl,liblibrary-callnumber-lc-perl,liblocale-maketext-lexicon-perl, liblog-log4perl-perl, libmarc-charset-perl, libmarc-record-perl, libmarc-xml-perl, libmodule-pluggable-perl, libncurses5-dev, libnet-ip-perl, libnet-ldap-perl,libnet-server-perl, libnet-ssh2-perl, libnet-z3950-simple2zoom-perl, libnet-z3950-simpleserver-perl, libnet-z3950-zoom-perl,libnspr4-dev, libole-storage-lite-perl, libparent-perl, libparse-recdescent-perl, libpcre3-dev, libpq5, libpq-dev, libreturn-value-perl, librose-uri-perl,librpc-xml-perl, libsoap-lite-perl, libsru-perl, libssh2-1-dev, libssl-dev, libtemplate-plugin-posix-perl, libtest-output-perl, libtest-warn-perl, libtext-aspell-perl, libtext-csv-perl, libtool,libuniversal-require-perl, libunix-syslog-perl, libuuid-tiny-perl,libxml-libxml-perl,libxml-libxslt-perl, libyaz-dev, php7.2, php7.2-gd, php7.2-pgsql, php7.2-xml, php7.2-dev, php-memcache, php-pear, postgresql-client-9.6, yaz
 Description: Evergreen Library Management Sofware.
  Evergreen is open-source, consortial-quality 
  library software to help library users find 
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
old mode 100755 (executable)
new mode 100644 (file)
index a238348..f654d47
@@ -11,17 +11,23 @@ export DH_VERBOSE=1
 export DEB_LDFLAGS_MAINT_APPEND= -lm
 INSTALL_FOLDER=debian/evergreen-ils
 INSTALL_WEB=/openils/var/web
-STAFF_BUILD=rel_3_4_0
+STAFF_BUILD=rel_3_6_1
 %:
        dh $@ 
 override_dh_auto_configure:
        ldconfig
        ./configure --prefix=/openils --sysconfdir=/openils/conf
 
-override_dh_auto_install:
-       #make -j1 DESTDIR=$(shell pwd)/$(INSTALL_FOLDER) WEBDIR="$(INSTALL_WEB)" STAFF_CLIENT_BUILD_ID=$(STAFF_BUILD) install
-       make -j1 DESTDIR=$(shell pwd)/$(INSTALL_FOLDER) WEBDIR="$(INSTALL_WEB)" STAFF_CLIENT_STAMP_ID=$(STAFF_BUILD) install
-       cd $(INSTALL_FOLDER)$(INSTALL_WEB)/xul && ln -s $(STAFF_BUILD)/server server
+override_dh_auto_build:
+       cd Open-ILS/src/perlmods
+       make
+       cd ../../..
+       make -j4
+
+#override_dh_auto_install:
+#      ##make -j1 DESTDIR=$(shell pwd)/$(INSTALL_FOLDER) WEBDIR="$(INSTALL_WEB)" STAFF_CLIENT_BUILD_ID=$(STAFF_BUILD) install
+#      make -j1 DESTDIR=$(shell pwd)/$(INSTALL_FOLDER) WEBDIR="$(INSTALL_WEB)" STAFF_CLIENT_STAMP_ID=$(STAFF_BUILD) install
+#      cd $(INSTALL_FOLDER)$(INSTALL_WEB)/xul && ln -s $(STAFF_BUILD)/server server
 
 override_dh_usrlocal:
        #Skiping dh_usrlocal
@@ -48,7 +54,7 @@ override_dh_install:
        echo "LoadModule xmlent_module      /usr/lib/apache2/modules/mod_xmlent.so" > "debian/evergreen-ils/etc/apache2/mods-available/xmlent.load"
        echo "LoadModule idlchunk_module    /usr/lib/apache2/modules/mod_idlchunk.so" > "debian/evergreen-ils/etc/apache2/mods-available/idlchunk.load"
 
-override_dh_shlibdeps:
-       dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
-override_dh_auto_test:
-       #skip!
+#override_dh_shlibdeps:
+#      dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
+#override_dh_auto_test:
+#      #skip!
old mode 100755 (executable)
new mode 100644 (file)
index c990d05..1ccf115
@@ -11,23 +11,28 @@ export DH_VERBOSE=1
 export DEB_LDFLAGS_MAINT_APPEND= -lm
 INSTALL_FOLDER=debian/evergreen-ils
 INSTALL_WEB=/openils/var/web
-
-## Change this to one that suits you consortium eg. pines_rel_x_x_x
-STAFF_BUILD=pines_rel_3_4_0
+STAFF_BUILD=pines_rel_3_4_2
 %:
        dh $@ 
 override_dh_auto_configure:
        ldconfig
        ./configure --prefix=/openils --sysconfdir=/openils/conf
 
-override_dh_auto_install:
-       #make -j1 DESTDIR=$(shell pwd)/$(INSTALL_FOLDER) WEBDIR="$(INSTALL_WEB)" STAFF_CLIENT_BUILD_ID=$(STAFF_BUILD) install
-       make -j1 DESTDIR=$(shell pwd)/$(INSTALL_FOLDER) WEBDIR="$(INSTALL_WEB)" STAFF_CLIENT_STAMP_ID=$(STAFF_BUILD) install
-       cd $(INSTALL_FOLDER)$(INSTALL_WEB)/xul && ln -s $(STAFF_BUILD)/server server
+override_dh_auto_build:
+       cd Open-ILS/src/perlmods
+       make
+       cd ../../..
+       make -j4
+
+#override_dh_auto_install:
+#      ##make -j1 DESTDIR=$(shell pwd)/$(INSTALL_FOLDER) WEBDIR="$(INSTALL_WEB)" STAFF_CLIENT_BUILD_ID=$(STAFF_BUILD) install
+#      make -j1 DESTDIR=$(shell pwd)/$(INSTALL_FOLDER) WEBDIR="$(INSTALL_WEB)" STAFF_CLIENT_STAMP_ID=$(STAFF_BUILD) install
+#      cd $(INSTALL_FOLDER)$(INSTALL_WEB)/xul && ln -s $(STAFF_BUILD)/server server
 
 override_dh_usrlocal:
        #Skiping dh_usrlocal
 
+
 override_dh_prep:
        rm -f debian/evergreen-ils.substvars
        rm -f debian/evergreen-ils.*.debhelper
@@ -38,7 +43,6 @@ override_dh_prep:
        cp -Rv Open-ILS/examples/apache_24/eg_24.conf       debian/evergreen-ils/etc/apache2/sites-available/eg.conf
        cp -Rv Open-ILS/examples/apache_24/eg_vhost_24.conf debian/evergreen-ils/etc/apache2/eg_vhost.conf
        cp -Rv Open-ILS/examples/apache_24/eg_startup    debian/evergreen-ils/etc/apache2/
-
 override_dh_fixperms:
        dh_fixperms
        @echo "DEBUG MARK"
@@ -50,8 +54,7 @@ override_dh_install:
        echo "LoadModule xmlent_module      /usr/lib/apache2/modules/mod_xmlent.so" > "debian/evergreen-ils/etc/apache2/mods-available/xmlent.load"
        echo "LoadModule idlchunk_module    /usr/lib/apache2/modules/mod_idlchunk.so" > "debian/evergreen-ils/etc/apache2/mods-available/idlchunk.load"
 
-override_dh_shlibdeps:
-       dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
-
-override_dh_auto_test:
-       #skip!
+#override_dh_shlibdeps:
+#      dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
+#override_dh_auto_test:
+#      #skip!